Corsmed Quick start & manual
v200319 / v200319

Corsmed Quick start & manual
Version v200319 / v200319

Introduction
The Corsmed Educational Platform is a simulator software intended for students, teachers
and operators to train, practice and learn MRI in a safe setting. The software allows the user
to run simulated scans directly on their computer, instead of having to rely on access to a
real scanner and a volunteering patient.
This document aims to help new users get started in the shortest amount of time,
furthermore, it aims to give experienced users a detailed description of all the possibilities
and settings in the simulator.
The document is structured in three parts. Part 1 focuses on getting into the scanner and
training in the easiest possible way. It gives the necessary steps to log in, to set-up and to
run the first scans. Part 2 focuses on giving a detailed description of the different settings
and possibilities that are presented in the simulator. Part 3 describes initial experiments that
can be run to give an idea of what the simulator is capable of, when these experiments have
been ran, the user is encouraged to explore the simulator further.
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1. Quick start
This section aims to help users get into, and run, the simulator the easiest way possible. It
contains two parts, the first one helps the user to login and start the simulator, while the
second part gives a brief instruction to settings and running scans.

1.1 Login and start-up
For accessibility, the platform has been built as a web-application.
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1. The platform is reached through any web-browser by going to
education.corsmed.com.
2. On the webpage, enter your credentials provided by Corsmed and press ‘Log in’.
3. After logging in, press ‘Start on a course or scanner you would like to run. For
instruction purposes, use the ‘Head/Neck/Brain imaging application’.
4. After pressing ‘Start, wait for the simulator to open in a new window. If it is the first
time you are opening the simulator, allow some extra time for the simulator to
connect.
a. Important: If the simulator is not opening, make sure you allow popups.
b. When the simulator has loaded, wait until the yellow text in the bottom right
corner reads “The virtual MR scanner is ready”.

1.2 Basic settings and instructions for the first scans
After successfully logging in and starting the simulator, it is time to run the first scans. To
start, first ensure that the following settings in the top left corner are selected:
1. Simulation > Noise > Off
2. Simulation > Isotropic grid > On 1mm
3. Simulation > Performance >
a. Simulate slice thickness > NOT checked
b. Fast algorithm > Checked
4. Simulation > Coil > Basic + Optimal Rx
5. Simulation > Motion > None
6. Simulation > Advanced >
a. Analytical simulation > NOT checked
b. Check spurious echoes > Checked
c. PD variability > Checked
d. Activate CS > Checked
If you have started the Whole-body application, use Tools > Isocenter > Whole body OR
regions to select where in the body you would like to place the Iso.
Pull up the SCOUT Images by clicking and dragging the sun/mountain symbol to the
respective image window (COR to the left, TRA to the middle and SAG to the right). The
scout images that appears will depend on where you placed the Isocenter. Should you want
to have a different set of scout images, first select the isocenter position, then close the
isocenter selection, then re-drag the scout images to the correct viewer.

1.2.1 Common functions
1. Scroll through image stacks:
a. Click the arrows (< and >) next to the image stack you want to scroll through.
2. Import a new MR sequence for planning:
a. Click ‘Add pulse sequence’ / ‘[any pulse sequence of choice]’ / ‘Import’ /
‘Close’.
b. Alternative: Right click a previous sequence in the list and choose ‘Clone’.
3. Planning a sequence for scanning:
a. Double click an unused sequence in the list (white background) to open the
sequence and modify its parameters.
b. Save scan plane and sequence parameter changes by clicking ‘Save’.
4. Change or alter the scan plane / slice position:
a. Move: Click and drag the scan plane line, or use the arrow keys.
b. Rotate: Rotate the scan plane using either:
i. Click and hold left mouse button + the mouse scroll wheel, or
ii. Shift + arrow keys (can be done without holding the mouse)
c. Change phase/frequency encoding directions (to avoid fold-over artefacts)
either:
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i. Rotate the slice(s) using any method above
ii. Right click the image on the viewer and choose ‘Change FE to PE’
iii. Select Foldover Direction in the Geometry tab.
d. Perpendicular plane to image in viewer: To get a plane that is
perpendicular to the image, right-click in the image on the viewer and choose
‘Perpendicular position’.
e. In-plane slice position. To get a plane that is in line with the image in the
image viewer, right-click in the image on the viewer and choose ‘In-plane
position’. A position that is In-plane will result in the same image as in the
viewer, assuming the same sequence and parameters is used.
5. Show images in the viewers:
a. If images are not automatically loaded or if you want to show other previously
acquired images: click and drag the sun/mountain symbol from the
sequence list to one of the view boxes.

1.2.2 The basics of running any experiment:
1. Load up the SCOUT images, and scroll through a location where you would like to
place a plane
2. Import/add a pulse sequence
3. Open the pulse sequence and alter the plane position and sequence parameters
4. Save the selection and run the scan
5. Analyse images and results
See section 3 for some initial experiments to follow along to get started.

2. Detailed instructions, settings and manual
2.1 Logging in and the Login screen
To allow anyone to train MRI with simulations, regardless of hardware and computer
knowledge, the platform has been built as a web-application, which needs no downloads or
installations.
The platform is reached through a web-browser by going to education.corsmed.com. Any
operating system (Windows PC or Apple MAC) can be used, and any web-browser
(Chrome, Internet explorer, Edge, Safari, Mozilla) can be used as well.

On the webpage, enter your credentials provided by Corsmed and press ‘Log in’.
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After logging in, you will be presented with the control panel.

2.2 Control panel
The control panel is where you access different courses and scanners and find general help
to run more scans.

In the top right corner, one finds the links Home, Control panel, Help and Logout:
1.
2.
3.
4.

Home – Brings you to the home page of the login
Control panel – Brings you to the general control panel page (above)
Help – Brings up this manual
Logout – Logs you out of the simulator and control panel
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In the table you will find the different scanners and courses and its different options:
Version
1. Select – Drop-down menu to select which version you wish to run, there is usually an
official stable version, as well as one pre-release version.
EduTool
2. Start – Starts and opens the selected scanner/course in a new tab (make sure you
allow popus). A version has to be selected before starting.
3. Open running – (Available if you have recently started a session that is running)
Opens the selected scanner/course in a new tab. A version has to be selected
before starting.
4. Reset – Deletes data and protocols and returns any custom settings to default
values. Usually only used to get new major updates.
After pressing ‘Start’, wait for the simulator to open in a new window. If it is the first time you
are opening the simulator, allow some extra time for the simulator to connect.
Important: If the simulator is not opening, make sure you allow popups.
After the simulator has loaded, you will see the following screen.

Wait until the yellow text in the bottom right corner reads “The virtual MR scanner is ready”,
then you are ready to run the simulated scanner.

2.3 Interface
If it is the first time you load the scanner, the following screen will be seen:
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As seen in the image below, the interface can be divided into the following 5 sections:
1.
2.
3.
4.
5.

General settings (top left) see 2.7
Indicators and information (top right) see 2.8
Three viewer screens for images and slice positioning (middle) see 2.6
Pulse sequence and protocol organiser (bottom left) see 2.4
Pulse sequence parameters window (bottom right) see 2.5

2.4 Pulse sequences
The pulse sequence organiser (the list), found in the bottom left of the interface, is used to
identify, load, organise and clone pulse sequences.
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Importing a new pulse sequence is done by clicking ‘Add pulse sequence’ (which brings up
the pulse sequence library), selecting the wanted pulse sequence, and clicking import in the
bottom left of the library list.
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An imported, not yet run, pulse sequence is coloured white, while an already run sequence
is coloured grey, as seen below:

Right clicking a pulse sequence allows one to rename, delete and clone pulse sequences.
Double clicking a pulse opens it, which allows one to set the parameters and slice position,
see 2.5 and 2.6.
After a pulse have been properly set, planned and saved, the ‘Run’ button can be clicked, a
loading bar will then indicate the simulation progress. Finished images are automatically
loaded on a viewer.
The orange text on the pulses describes the time it would take to run the scan in real life.
This time is only visible if the scan was running with the “Analytical simulation” -option
unchecked (see 2.7).
If simulations are run with coils (other than Optimal Rx), the SAR will be seen in red next to
the scan time in real life.
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Any resulting image from a pulse can be viewed on the viewers by clicking and dragging the
mountain/sun image on a pulse to a selected viewer.

2.5 Pulse sequence parameters
The pulse parameter settings are used to manipulate the pulse, and thus SNR, contrasts,
simulation times and more. By double clicking a loaded pulse sequence, the parameter
settings window is shown in the bottom right of the interface, as seen below.

The window will allow the user to manipulate different settings on the pulse. Indicators for
Relative SNR, Voxel sizes, Plane orientation and Scan-time IRL will always be seen on the
bottom right. Other settings are shown in different tabs. After a slice have been set, click the
save button to save the sequence before running.
The following tabs and settings can be found:
1. Geometry
a. Field of view Read, in mm, with corresponding direction RL/AP/FH
b. Field of view Phase, in mm, with corresponding direction RL/AP/FH
c. Foldover direction, in direction RL/AP/FH
d. Resolution/Matrix Read, as pixels
e. Resolution/Matrix Phase, as pixels
f. Slices, in numbers
g. Slice thickness, in mm
h. Slice gap, in mm
2. Sequence
a. Echo time, TE, in ms
b. Repetition time, TR, in ms
c. Bandwidth, as total Hz
d. Bandwidth/pixel, in Hz
e. NEX/NSA/Averages, number of excitations
f. Flip angle, in degrees
g. Foldover suppression (over sampling)
3. Special (only shows up if the pulse has special parameters that are not available on
all pulses)
a. Turbo factor/ETL, in numbers, with Effective echo time indicator
b. Fat suppression, different selections
c. Fat sat. Inversion Time (TI), in ms
d. IR type
e. IR duration, in ms
f. Inversion Time (TI), in ms
4. Reconstruction (usually left as default)
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a. Reconstructor, interpreting signals into images
b. Shift K-space lines 1 pixel, used to manipulate ghosting artifacts in EPIsequences.
5. Advanced (typically not found in clinical scanners without unrestricted access to
scanner software)
a. RF duration, (duration of the RF pulse) in ms

2.6 The viewers and slice planning
The three viewers in the middle of the interface allows the user to make the slice planning,
as well as to analyse the images after the scans have been run.
To view an image on a viewer, drag and drop the mountain/sun symbol from the sequences
list to one of the viewers.
After dragging the SCOUT images to the viewers, and importing and opening a pulse
sequence, the slice position will be given by the yellow lines in the images.

Selecting a viewer can be done by left clicking it. A selected viewer can be identified by the
orange frame around it.
Moving the slice can be done by clicking and dragging the border of the slice in a viewer.
Alternatively, the arrow keys can be used to move the slice.
Rotating the slice can be done by using the scroll wheel on the mouse or by using SHIFT +
arrow keys.
Right clicking a viewer gives the following actions:
1. Copy image position, copies the position of the plane for acquiring the same image.
An image position can also be copied from a previously run sequence by rightclicking it in the protocol list.
2. In-plane position, places the slice at the center of the image, and in line with the
image in the viewer. (In-plane will give the same image as in the viewer, assuming
the same parameters and sequence is used)
3. Perpendicular position, sets the slice to be perpendicular to the selected viewer.
4. Change FE to PE, changes the frequency encoding direction to phase encoding
direction (foldover direction), rotates around, 90’ at a time. This can also be
changed in the Geometry tab, or simply by rotating the slice
The arrows on the yellow lines/box of the plane identifies the Phase encoding direction
(PE), important for avoiding fold over artefacts.
The orange lines identifies the position of the active viewers position in the other viewers.
The blue lines in a viewer identifies where the non-active viewer appear in the other
viewers. The dashed line marks the intersection line of the plane and the image in the
viewer.
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Contrast and brightness can be manipulated in a viewer by holding SHIFT + CTRL and
pressing the arrow keys (windowing).

2.7 Software settings and tools
The settings menu in the top left corner allows the user to alter the way the simulator
behaves and creates images.

The following actions and settings are presented:
1. Session
a. Save and Close – Saves the protocols and data, and closes the session,
returning the user to the control panel. Note: If a user is idle for more than 15
minutes, the session will automatically save and close. Furthermore, Saving
the session is automatically done even if the web browser is closed first.
b. Reset – Deletes all pulses that have been run, as well as returns any custom
settings to default values
2. Simulation
a. Noise
i. Allows the user to turn noise on or off, the advanced button also
opens a selection menu to alter how much background noise that is
added when the setting is on
b. Isotropic grid
i. If turned on, the simulation platform applies a re-gridding method on
the anatomical model so as to create a constant distance of
consecutive spins along the three dimensions (x,y,z). This increases
the simulation time but gives more realistic images.
ii. Having isotropic grid on will remove eventual simulation based
artifacts that may appear
iii. Using a more granular grid (1mm, 0.5mm and Optimal) will give
slightly more realistic images, but will also increase simulation time
slightly.
c. Performance
i. Simulate slice thickness – Turns slice thickness simulation on or off.
Checking this option is a more realistic choice, and gives more
realistic looking images, but increases the simulation time. Having
slice thickness off will result in images with very sharp edges between
anatomical borders, i.e. there will be a clear distinction exactly where
two different tissues will border. Having slice thickness off is useful in
some educational scenarios, such as when looking at contrast in
specific tissues.
ii. Fast algorithm – Compresses the pulse sequence so to reduce the
simulation time. The amount of compression depends on the design of
the pulse sequence
d. Coil
i. Allows the user to select different receiver and transmitter -coils.
ii. Basic/Advanced selects between two types of signal- and distribution
maps. Advanced allows for signal outside the area of decay. Basic is
the recommended default selection.
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iii. 10 different coils can be selected. Optimal Rx gives an optimal Rx,
which means that is a perfect receiver (perfectly uniform field
distribution, zero phase).
e. Motion
i. Allows the user to add Translational and Rotational motion of the
patient/model. The options button allows the user to manipulate how
much motion that is added.
f. Advanced
i. Analytical simulation – Turns analytical simulations on or off.
Analytical simulations are fast but non-realistic. Not recommended for
education.
ii. Check spurious echoes – Checks whether the design of the pulse
sequence and the density of the computer model will cause the
appearance of simulation-based artefacts in the images.
iii. PD variability – Checking this option gives the anatomical model an
inhomogeneous structure to all tissues. Unchecking this option makes
tissues in the anatomical model homogenous.
iv. Activate CS – Checking this option enables Chemical shift as an
artifact in the simulator.
v. Dwell time – Changes the temporal step that the simulator is using.
Dynamic is recommended, as it improves performance slightly.
vi. Open tissue characteristics window – Allows the user to manipulate
the magnetic properties of the anatomical model. The properties
provided are grounded in Corsmed’s research and literature.
However, there are different characteristics in different studies, as
such we allow the user to alter the values in case opinion differ.
3. Tools
a. Image viewer – Opens a tool to view the resulting images on a larger viewer.
Also allows downloading the images in Dicom and JPG/PNG -formats. The
image viewer also presents a tool to let users mark Regions of Interest (ROIs)
i. The ROIs gives the average pixel intensity. These areas can be
selected using the Free-hand tool or the Circle tool
b. Tool’s configuration
i. Open image viewer mode – Changes if the Image viewer (above)
should open as a popup or in a separate tab
ii. Open notifications history mode – Changes if the Notifications
history (see 2.8) should open as a popup or in a separate tab
iii. Open base noise level tool mode – Changes if the Advanced base
noise level tool (see noise above) should open as a popup or in a
separate tab
iv. Open tissue characteristics tool mode – Changes if the tissue
values should open as a popup or in a separate tab
v. Open K-space tool mode – Changes if the K-space should open as a
popup or in a separate tab
c. Display options
i. Show text on viewers – Checking this option will display information
on finished sequences/images in the corners of the image.
ii. Show intersections on active viewer – Toggling this will show extra
blue lines on the active viewer (otherwise the blue lines are hidden on
the active viewer), see 2.6
iii. Show tissues on hover (image viewer) – Checking this option will
enable the user to, within the image viewer (3.a), be able to hover the
mouse above the tissue in an image, and get a note which tissue it is.
d. Gradients
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i. Coming soon!
4. Options
a. Units
i. Distance – Changes the parameters displayed distance unit,
mm/cm/m
ii. Time – Changes the parameters displayed time unit, ms/s/min
b. Auto-run – Toggles whether multiple sequences or protocols should be run
after one another (when one is finished).

2.8 Software indicators and information
The indicators in the top right corner allows the user to get information regarding the
simulator and simulations.

The following indicators are presented:
1. Time icon – Gives the amount of allowed time that is left for the user. All users that
are on the yearly plans have infinite time and access
2. Bell notifications icon – Clicking this button presents all errors and notes that have
been produced during the usage
3. Version information – Clicking this gives the current version the user is running
4. Connection status – Clicking this pops up a message on how well the connection to
the simulation server is
a. Should the connection drop during operations, this indicator will change to
inform of that
5. Username – Clicking this allows the user to return to the control panel
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Section 3: Example experiments with instructions
The following experiments can be used as an initial starting point to get started with the
simulator. As soon as the user feels comfortable with the software, one should freely explore
and develop own experiments.

Experiment 1: Cardiac manual planning for the short-axis scan plane
Load the ‘Corsmed Whole body application’ in the Control panel.
In the menu ‘Imaging’ in the top left, ensure the following is selected:
1. Simulation > Noise > Off
2. Simulation > Isotropic grid > On 1mm
3. Simulation > Performance >
a. Simulate slice thickness > NOT checked
b. Fast algorithm > Checked
4. Simulation > Coil > Basic + Optimal Rx
5. Simulation > Motion > None
6. Simulations > Advanced >
a. Analytical simulation > NOT checked
b. Check spurious echoes > NOT Checked
c. PD variability > Checked
d. Activate CS > Checked
Click on the menu item ‘Tools’ -> ‘Isocenter’. At the popup window, drag the isocenter line
(orange line) close to the patient’s heart. Close the iso-center selection.

Pull up the Scout Images by clicking and dragging the sun/mountain symbol to the
respective image window (COR to the left, TRA to the middle and SAG to the right).
1. The first step is a so-called pseudo two-chamber image:
a. Load a new sequence for planning and double click it to open.
b. Position the scan plane so that it crosses through the left atrium and left
ventricle (Figure 1).
c. Click the left view box to choose this as the active view for the planned image,
click ‘Save’ and ‘Run’ (Figure 2).
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Figure 1. Planning the pseudo two-chamber image as a first step towards a short-axis image. It is important that
the slice is outside the body in the phase-encoding direction to avoid fold-over artefacts.

Figure 2. The result of step one, a pseudo two-chamber image (left view box).

2. The second step is a pseudo four-chamber image:
a. Load a new sequence for planning and open it.
b. Position the scan plane through the left atrium and left ventricle in the pseudo
two-chamber image (Figure 3) and click the rightmost view box, save and run
the sequence (Figure 4).

Figure 3. To reach the pseudo four-chamber image, position the scan plane through the left atrium and left
ventricle in the pseudo two-chamber image (left view box).
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Figure 4. The result of the second step is a pseudo four-chamber image (right view box).

3. Third and last step for the short-axis image:
a. Load a new sequence for planning and open it.
b. Position the scan plane through the left and right ventricles at the
midventricular level in the pseudo four-chamber image, perpendicular to a
long-axis through the left ventricle (Figure 5). Click the middle view box, save
and run the sequence (Figure 6).

Figure 5. To reach the short-axis image, position the scan plane through the left and right ventricles at the
midventricular level in the pseudo four-chamber image, perpendicular to an imagined long-axis through the left
ventricle (right view box).

Figure 6. The result of the third step is a short-axis midventricular image (middle view box).
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Experiment 2: Routine brain magnetic resonance imaging examination,
Navigate through the human head-neck anatomy
Load the ‘Corsmed Head/Neck application’ in the Control panel.
In the menu ‘Imaging’ in the top left, ensure the following is selected:
1. Simulation > Noise > Off
2. Simulation > Isotropic grid > On 1mm
3. Simulation > Performance >
a. Simulate slice thickness > NOT checked
b. Fast algorithm > Checked
4. Simulation > Coil > Basic + Optimal Rx
5. Simulation > Motion > None
6. Simulations > Advanced >
a. Analytical simulation > NOT checked
b. Check spurious echoes > NOT Checked
c. PD variability > Checked
d. Activate CS > Checked

Figure 1. The settings menu

1. Pull up the Scout Images by clicking and dragging the sun/mountain symbol to the
respective image window (COR to the left, TRA to the middle and SAG to the right).

Figure 2. SCOUT images loaded

2. For the transversal slice presented in the previous image, acquire:
a. A GRE image with a FOV equal to FE = 0.3m and PE = 0.3 m and a matrix
size equal to matrix-x = 256 and matrix-y = 256
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b. A bSSFP image with a FOV equal to FE = 0.3m and PE = 0.3 m and a matrix
size equal to matrix-x = 256 and matrix-y = 256
c. An IR-bSSFP image with a FOV equal to FE = 0.3m and PE = 0.3 m and a
matrix size equal to matrix-x = 256 and matrix-y = 256
The MR images should look like the ones presented in the next figure:

Figure 3. Final images

IMPORTANT NOTE: Please note the longer simulation time needed for these experiments.
In these experiments a larger volume (the menu item ‘Simulate slice thickness’ in active) is
used in order to generate more realistic MR images.
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